Scheduled for February 12, 2026 at 10:30 AM – 12:30 PM
Affects
Internet
Under maintenance from 10:30 AM to 12:30 PM
Voice
Under maintenance from 10:30 AM to 12:30 PM
TV
Under maintenance from 10:30 AM to 12:30 PM
Completed
February 12, 2026 at 12:30 PMCompleted
February 12, 2026 at 12:30 PMMaintenance has completed successfully
In progress
February 12, 2026 at 10:30 AMIn progress
February 12, 2026 at 10:30 AMMaintenance is now in progress
Planned
February 12, 2026 at 10:30 AMPlanned
February 12, 2026 at 10:30 AMPella Fiber will be performing maintenance on Thursday 2/12 between the hours of 4:30AM and 6:30AM. Customers in the following service areas may see a brief loss of all services as the maintenance is completed:
SA09
SA20
SA07
SA25
SA28
SA08
Please click the Open Status Page link to view a map of the service areas.